Moving Emitter Problem

Hello,

I just started testing with Eddy and encountered a problem I’m not sure how to fix.

I have set up animation on an emitter. As it accelerates the smoke trail starts to break up into a dotted line. I can’t figure out how to maintain a solid emission as the emitter starts moving. Any suggestions would be appreciated.

do you have a simple example scene you can share?

I can’t export anything from the studio, but you can replicate the dotting emission in one of your example scenes.

Animate the e_sphere’s translation X value in the “eddy_drifting_smoke_sparse_example.nk” scenefile.
frame 1 tx ==0
frame 150 tx = -200

Now when you play back the emission breaks up into dots. I can’t figure out how to get the emission to maintain a solid stream of smoke when the emitter is animated like this.

Ah, I see. Interesting. It seems like Eddy doesn’t compute sub frames for emitters even when the max time step value is increased. Might have to wait for one of the exports/devs to jump in.

Hi there,
This is something that is being fixed in an upcoming release for Eddy.

There is however a feature in current builds that will work in some cases. On the Distort node you can set it to “Mblur” and motion blur your field by incoming vectors. This is easiest to do from a MeshToVolume field as its vector feild can be easily fed into the Distort as the channel offset. This often can blur the field enough to eliminate gaps/steps etc.

image

Hope this helps a little for now, and keep a look out for the proper fix in upcoming builds.

Thanks guys, I’ll give that a try

1 Like

Thats a great tip Matt!! Thanks for that!

1 Like

hello friends where can i purchase eddy any website other than this

Hi there craftsmen,
Send an email to sales@intraware.com.au to request a license.

I am running into the same issue as well. Adjusting motion blur doesn’t really do anything…has there been an update with a setting or process to calculate the sub-frame space between positions?

Cheers.

Hi Ed,

The thread was originally in regards to Eddy 1..
I assume you’re using Eddy 2.
, which no longer relies on Nuke to handle sub-stepping and handles all the graph interpolation/sub-stepping now internally to overcome the original issue mentioned here.
I might need more information on your effect, but I thought its worth mentioning something you can try quickly.

In case your emission source is moving large distances from frame to frame it helps to increase the Min Time Steps parameter in your simulation element. Increasing the min/max step parameter will enforce sub-stepping of emission inputs, particularly if they don’t modify the velocity field.
The sub-stepping algorithm used by default is velocity based and only triggers more sub-steps as the ratio of the largest velocity in the your simulation increases in respect to your voxel size. The larger the ratio, the more steps the simulation should take.

The above graph motion blur setup can be used in conjunction with the sub-stepping. It can speed things up, if taking simulation sub-steps is too slow in your case ( eg if its a very large simulation ), but it requires a correct velocity field describing the object’s motion.

I hope this helps a bit.

Cheers,
Christoph

Ah, the min/max steps! Thank you, I’ll give that a try.

Cheers.