Mesh To Volume , volume does not match the .abc

Hi,

How can I reduce the difference of volume between the Geo ( .abc) and the volume generated by Eddy ?
I need to have the volume matching the size of the geo closer than that it is at the moment.

I’ve noticed this a lot also… It seems on some meshes but not others for me… let me do some tests with different geometry setups.

Ive worked it out.
image

You need to have a sealed mesh. The example above of this cartoony character, if i delete the bottom faces on the legs, it puffs out. With the legs sealed, it matches nicely.
I tested around 10 meshes of different resolutions and from my own work and other character artists… it seems scale has no effect, and triangles are ok.

I’ll raise a ticket for this with Vortechs.

cheers!

Quick response from @christoph
yes because it generates a shell with an artificial thickness. i need to check but i think its 1 voxel thick at that stage. if you want the correct collision volume it needs to be water tight.

to use collisions you need an inside/outside region. if its just a shell there is no volume, but just a simple surface with no inside ( think of a plane vs a box ). so we artificially increase the thickness to allow collisions again.

In an upcoming version this thickness value should be an adjustable parameter, but best to make a sealed volume.

MB

Hi Andre,

I’ll see if I can get this additional control into the next release so you have a bit more control over this.
We’re aiming to do this towards the end of the week.

Cheers,
Christoph

Cool thanks___________________

Hi Andre,
I found a few small issues on the mesh that probably triggered Eddys code into thinking its unsealed. There were a few faces with flipped normals, and the big Ngon on the end was a possible cause. Unsure.
Anyway, i corrected the mesh for you, i’ll send to you seperately.

image

image

1 Like