Embedded Lights and Thin Volume

Hi all, I have a sequence I have been rendering of static perlin noise volumes with some bright embedded point lights. Equi-Angular sampling doesn’t seem to help or even cranking progressions to 1200, I just keep getting black squares and the thinnest parts will flicker. Any ideas? Thanks!

Hi Tim,

Here’s a couple of suggestions/guesses that might help, in recommended order:

  • Enable “Thin media sampling”. This can help when the volume is very optically thin (i.e. almost transparent). This option is only available when using the “tracking” integrators. If you’re currently using the raymarching integrators try switching to tracking (for non-voxel-based volumes Eddy will often switch to tracking integrators regardless of your setting as raymarching is not possible - there’s a warning in the log about this but otherwise Eddy doesn’t make a fuss).
  • Switch to the raymarching integrators and set the “feature size” in the E_Shader node. This should be the size of the smallest details in your volume, which might not be practical when you have a highly detailed implicit volume, but start it fairly high (e.g. 1% of your volume dimensions) and reduce until there’s enough detail and performance is still acceptable. This is why the tracking integrators are preferred for implicit volumes, they don’t need the feature size to be set and can still show the high detail.
  • Disable the supervoxels. The black squares you describe might be the supervoxels becoming visible. It’s possible there’s a bug in the supervoxels, but try the previous suggestions first, as they are probably just a symptom rather than the cause.

If you can share your scene I’m happy to take a look at it too, even if one of the suggestions works. Either share here or send to support@vortechsfx.com

Thanks,
Niall.