Eddy for Nuke for Nuke12.2

Hi,
I could not reply to Eddy for Nuke 2.6.1 thread on Release category,
so I’ll make a new thread over here.

Is it possible to build one for Nuke.12.2?

Thanks in advance,
Taku

Hi @wakisaka,

We will be adding Nuke 12.2 builds on the next release. For now I can take a look at getting them on to your download portal this weekend for the current version.

Kind regards,
–Ronnie

Thank you Ronnie.

I’ve looked at the download portal for Nuke12.2 build,
but I could not find any.
Have you had a chance to build it?

Best regards,
Taku

Hi @wakisaka,

Apologies for the delay in getting 12.2 builds up. They’re there now for you to test. Let me know if you have any troubles with them.

Kind regards,
–Ronnie

Thank you Ronnie,
I was able to download 12.2 builds.

I don’t know if this is from our setup,
but I am noticing this error when I create a node:

/path/to/eddy/12.2/EddyRender.so: undefined symbol: uuid_generate_time_safe

EddyRender.so for 12.1 also has a dependency to uuid_generate_time_safe, and that’s working fine fine,
so really don’t know why I am experiencing this error just for 12.2.

Currently, I am working it around by setting LD_PRELOAD to load in the libuuid.so in advance,
but wanted to ask if anything has changed between 12.1 and 12.2 build.

Best regards,
Taku