Disabling nodes does not have the expected effect

Hi all,

I have been wondering about why Eddy nodes don’t behave as expected when they are disabled. In the below example, when disabling the E_Merge node, I’d expect to see the unmodified E_PerlinNoise, but instead the viewer keeps showing the E_Merge’s effect.
Why is that?
I assume that sometimes in this scenario the output data type may change and Eddy would be left with an invalid node setup?! But I’d expect an error message in those cases (like when a regular Nuke node is set to use a channel that doesn’t exist).

Or is this simply an oversight?

Cheers,
frank

set cut_paste_input [stack 0]
version 11.3 v3
EddySphere {
inputs 0
eddy_plugs "\{\"plug_list\":\[\{\"array\":false,\"enabled\":true,\"hidden\":false,\"index\":0,\"internal\":true,\"name\":\"transform\",\"optional\":true,\"type_name\":\"M44f\",\"user\":false\}]\}\n"
crop_bbox {-0.5 -0.5 -0.5 0.5 0.5 0.5}
name E_Sphere9
selected true
xpos -8608
ypos -1907
}
EddyIsoMask {
eddy_plugs "\{\"plug_list\":\[\{\"array\":false,\"enabled\":true,\"hidden\":false,\"index\":0,\"internal\":false,\"name\":\"field\",\"optional\":false,\"type_name\":\"Field\",\"user\":false\}]\}\n"
mode "\{\"enum_list\":\[\{\"name\":\"scalar\",\"pretty_name\":\"Scalar\"\},\{\"name\":\"vector\",\"pretty_name\":\"Vector\"\}],\"enum_value\":\"scalar\",\"last_valid_enum_value\":\"scalar\"\}\n"
transform_type "\{\"enum_list\":\[\{\"name\":\"Vector\",\"pretty_name\":\"Vector\"\},\{\"name\":\"Coordinate\",\"pretty_name\":\"Coordinate\"\},\{\"name\":\"Normal\",\"pretty_name\":\"Normal\"\}],\"enum_value\":\"Vector\",\"last_valid_enum_value\":\"Vector\"\}\n"
crop_bbox {-0.5 -0.5 -0.5 0.5 0.5 0.5}
name E_Mask3
selected true
xpos -8608
ypos -1883
}
push $cut_paste_input
EddyPerlinNoise {
eddy_plugs "\{\"plug_list\":\[\{\"array\":false,\"enabled\":true,\"hidden\":false,\"index\":0,\"internal\":true,\"name\":\"transform\",\"optional\":true,\"type_name\":\"M44f\",\"user\":false\}]\}\n"
mode "\{\"enum_list\":\[\{\"name\":\"scalar\",\"pretty_name\":\"Scalar\"\},\{\"name\":\"vector\",\"pretty_name\":\"Vector\"\}],\"enum_value\":\"vector\",\"last_valid_enum_value\":\"vector\"\}\n"
transform_type "\{\"enum_list\":\[\{\"name\":\"Vector\",\"pretty_name\":\"Vector\"\},\{\"name\":\"Coordinate\",\"pretty_name\":\"Coordinate\"\},\{\"name\":\"Normal\",\"pretty_name\":\"Normal\"\}],\"enum_value\":\"Vector\",\"last_valid_enum_value\":\"Vector\"\}\n"
frequency {1 1 1}
vector_amplitude {1 1 1}
crop_bbox {-0.625 -0.625 -0.625 0.625 0.625 0.625}
name E_PerlinNoise5
selected true
xpos -8792
ypos -1969
}
EddyComposite {
inputs 2
eddy_plugs "\{\"plug_list\":\[\{\"array\":true,\"enabled\":true,\"hidden\":false,\"index\":0,\"internal\":false,\"name\":\"fields\",\"optional\":false,\"type_name\":\"Field\",\"user\":false\}]\}\n"
mode "\{\"enum_list\":\[\{\"name\":\"add\",\"pretty_name\":\"Additive\"\},\{\"name\":\"sub\",\"pretty_name\":\"Subtract\"\},\{\"name\":\"mul\",\"pretty_name\":\"Multiply\"\},\{\"name\":\"div\",\"pretty_name\":\"Divide\"\},\{\"name\":\"min\",\"pretty_name\":\"Minimum\"\},\{\"name\":\"max\",\"pretty_name\":\"Maximum\"\}],\"enum_value\":\"mul\",\"last_valid_enum_value\":\"mul\"\}\n"
crop_bbox {-0.5 -0.5 -0.5 0.5 0.5 0.5}
name E_Merge30
tile_color 0x4a5ec4ff
selected true
xpos -8792
ypos -1883
disable true
}
Viewer {
frame_range 1001-1766
fps 25
center_fstop 0
gl_lighting true
name Viewer2
selected true
xpos -8792
ypos -1847
}

HI Frank,

this is probably a bug on our side. I’ll double check your scene asap.

Cheers,
Christoph