Can't light the fire

Hi guys,

I just tried to use an image to drive the fuel on a wall (front side of an EddyBox). The sim seems to be reacting ok but the fire won’t ignite, I just get smoke.
Can someone have a looksee please?

Cheers,
frank

Heya frank, here’s a script with a few changes to improve the effect, and show some other techniques.
https://www.dropbox.com/s/qm17che0o9685h1/burningSmiley2.nk?dl=1

The parts in your script that were causing issues:

  • buoyancy was set at 1. This makes any combustion effect explode upwards too fast, despite of time steps this will stop the solver from working. You only need tiny buoyancy for combustion as temperature does the rest. 0.001 - 0.01 sort of range is what i play with, usually on the lower end. The defaults need to be changed here.
    -the density box you had was enveloping the temperature a bit, doubled up by the fact that the temperature area was really small and not hot enough.

Things I’ve changed and notes:

  • larger scene in general, the smiley was only about 20cm or so large. Being thin, there wasnt a lot of room to start an interesting combustion going. Solver works quite different at different scales.
  • large heat area, and hotter. Less density more fuel, check the masks and emitter multipliers.
  • added a distortion with perlin noise animated. This field drives the fuel and density, breaking up initial shape and creating more interesting emission
  • tweaked shader temperature coefficient.

There’s a few more bits I’ve tweaked, time steps and buoyancy.
Anything else you find just ask.

Hope this helps
Have fun :slight_smile:

Thanks, I will take a look at this when I free up again.
You are bringing up an interesting point: what units does Eddy assume Nuke t be at?
Nuke is unit-agnostic so it’s important to be very transparent with this.

My understanding is one nuke unit is 1m to Eddy, multiplied by the dimension size in element.

Matt Barker

Is that made obvious somewhere? It’d be good to be able to define what a unit is interpreted as (if that sort of control isn’t already in there somewhere - don’t have time to check right now)

yeah the dimension size in Element is how you define a scale factor. Nothings too obvious at this stage, as docs are being worked on and tutorials. Not too long before some new tutorials are up.

hmmm. default dimensions are 1.5 along all three axes. indeed a bit confusing.
I’d love to see a unit drop down with options to interpret Nuke’s unit as cm, inch, m, etc
that would be nice and transparent.

1 Like

Hi Frank,

we’ve reworked and simplified this logic and it will be in the upcoming version.

cheers,
Christoph

1 Like

Nice! Thanks Christoph