Caching to disk starts with incorrect frame

So maybe another noob mistake but:
I got a sim that starts at frame 1001. I have cached it in the viewer up to frame 1010, then decided that it’s good to go and hit render on my subsequent E_Cache node. The vdb sequence on disk starts with frame 1010 rather than 1001.
I cancelled the vdb export, set the play head in the viewer to frame 1001, reset my E_Element node, then hit render again on the E_Cache node. Now it is starting to write frame 1002.

I always tell it to render the global range which starts at 1001 and there are no custom settings in the E_Cache node other than the custom output path.
This is Eddy v2 latest build.

Can somebody verify that?

Cheers,
frank

Hi Frank,

Tried to reproduce this but without success so far. I ran a sim in the 3d viewer up to frame 1010, hit render on the E_Cache for a range 1001-1005, and the vdb files saved are 1001-1005 as expected. Maybe some unexpected detail is breaking it, could you share your script?

Thanks,
Niall.

Here you go.
Here are my steps to reproduce the issue:

  1. go to frame 1001
  2. reset the sim
  3. while viewing the E_mask node start playing back the viewer to see the sim result on the fly
  4. after a few frames (at frame 1007 in my recent test) stop the viewer.
  5. go to the E_Cache node and hit “WriteCache” (for the global frame range)

The first few frames will be ignored and the first frame on disk will be 1007 (or so)

Cheers,
frank
Eddy_cache_test.nk (24.3 KB)

Hi Frank,

Looks like this bug only affected the Linux version. This bug is now fixed and the next release should behave as expected.

Cheers,
–Ronnie

1 Like

awesome, thank you!

and because I have to post at least 20 characters with this forum software and a simple “thank you” is too short I just wrote this completely pointless sentence :slight_smile:

1 Like